header

Fehlfunktionen in WP 3.5.1

WP 3.5.1. brachte leider nicht die erhofften Behebungen von wesentlichen Fehlern und vor allen Dingen nicht von den Verschlimmbesserungen von WP 3.5 (Berichte).

Im Gegenteil. Es kam mindestens ein neuer Fehler hinzu. Daher: Auch mit 3.5.1 sind die Erfahrungen negativ:

Der umständliche Medienhochlader (media uploader) läßt einen keinen Text mehr direkt eingeben. Das geht gar nicht, weil die Felder viel zu winzig sind, so wie sie zusammengepreßt wurden und weil man ständig skrollen muß. Denn der Medienhochlader öffnet neu eine ganze Galerie. Man kann also nicht mehr einfach schnell ein Bild hochladen. Sondern erst wird ne ganze Mediathek an Bildern geöffnet, die kein Mensch braucht, wenn er einen aktuellen Beitrag schreibt.

Möchte mal wissen, was man sich dabei gedacht hat. Besonders schlimm ist es für alle, die kein Glasfaser haben, in den Alpen sind oder ein mobiles Internet im Zug nutzen und nicht gerade in Zürich oder in St. Gallen herumfahren mit der Bahn.

Aber zurück zur Sache.

Beim neuen extrem langsamen und extrem umständlichen Medienhochlader von WP 3.5 muß man mehrfach klicken, bevor man ein Bild von der Festplatte hochladen darf. Doch dann beginnt der Terror eigentlich erst. Man kann nicht mehr einfach kurz die Bildbeschreibung angeben und den Alternativ-Text usw. usf. und das Bild schnell rechts- oder linksbündig ausrichten. Nein. Es ist alles so kleingequetscht, daß man das Bild erst einfügen muß, dann nochmals öffnen muß und dann die Beschriftung machen darf.

Und hier ist der neue Fehler bei WP 3.5.1

Öffnet man das Bild nochmals und hat es bereits bündig im Text (z. B. rechtsbündig) eingefügt und gibt nun einen Alternativ-Text und eine Bild-Beschriftung ein und klickt auf Speichern, so verschwinden Teile des Blogbeitrags ohne ersichtlichen Grund.

Ich hab das Bild dann genervt ohne Beschriftung gelassen. Das passiert übrigens nicht beim Alternativ-Text. Den nimmt WP 3.5.1 noch an, ohne den Blogbeitrag zu zerstören. Aber wenn man die Beschriftung eingibt, dann wird der Blogbeitragstext zefetzt.

Siehe Fotos:

WP 3.5.1: Das Bild hat noch keinen Text, weil das seit WP 3.5 derart umständlich ist, daß man erst in einem Arbeitsschritt das Bild hochlädt und es danach nochmals öffent und dann den Text eingibt.

WP 3.5.1: Das Bild hat noch keinen Text, weil das seit WP 3.5 derart umständlich ist, daß man erst in einem Arbeitsschritt das Bild hochlädt und es danach nochmals öffent und dann den Text eingibt.

Nachdem man einen Bildtext eingegeben hat und auf Speichern klickt, ist ein Teil des Blogbeitragstextes weg. Super Fehlfunktion in 3.5.1

Nachdem man einen Bildtext eingegeben hat und auf Speichern klickt, ist ein Teil des Blogbeitragstextes weg. Super Fehlfunktion in 3.5.1

Share

Weiteres WP 3.5-Problem: Video mittig einbinden bei WordPress 3.5

Wie schon mehrfach berichtet, macht WordPress 3.5 massenhaft Probleme.

Bei einem auf WP 3.5 aktualisierten Blog geht auf einmal das mittige Einbinden von Videos nicht mehr.

Wer das gleiche Problem hat, kann hier eine Lösung finden, nach der ich grad verärgert – einmal mehr – viel Zeit für die Lösungssuche für Probleme, die es vorher nicht gab, verbringen mußte.

Wer ein Video, zum Beispiel von YT markiert und dann auf mittig klickt, bekommt angezeigt, daß das Video nun mittig ist. In der Html-Ansicht, die neu widersinnigerweise Text-Ansicht heißt, obwohl sie ja alles andere als Text, sondern eben Html ist, sieht man auch den eingefügten Kode:

<p style=”text-align: center;”>

Nach dem Speichern und wenn man den Blogbeitrag ansieht, ist es aber wieder nicht-mittig, sondern linkbündig, was häßlich aussieht.

Die Lösung für das neue bzw. neugeschaffene / neu-auftauchende WP 3.5-Problem, die ich nach langem Suchen gefunden hab:

Einfach vor dem Beginn des Html-Kodes des Videos in der Html-Ansicht (die neu fälschlicherweise Text-Ansicht heißt) eingeben:

<center>

Und nach dem Video eingeben:

</center>

 

 

 

Share

WordPress: Nach Umstellung auf WP 3.5 geht Bilder-hochladen nicht mehr

In der Mediathek sind die Bilder da

Lauter Probleme mit WP 3.5: In der Mediathek sind die Bilder da

Ich habe verschiedentlich über die massiven Probleme (hier z. B.  oder hier) und Nachteile / Verschlechterungen (z. B. hier) bei der Umstellung auf die WP-Version 3.5 berichtet, welche man auch überall im Internet nachlesen kann. Speziell bei der Bildhochladefunktio gibt es massivst Verschlechterungen (siehe hier oder auch hier)

Für mich ist WordPress 3.5 eine wirklich Verschlimmbesserung oder wie man das nennen soll. Besonders das Bilder-hochladen ist extrem umständlich geworden.

Nun kommt immer die bescheurte Fehlermeldung “Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.”

Auf WPDE.org schreibt jemand:

Dann wollte ich einen Beitrag erstellen, stellte aber erstmal fest, daß ich über die Mediathek nicht auf meine Bilder gelange (da wird nichts angezeigt) und wenn ich ein Bild hochladen möchte, kommt der Fehler:

Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.

Auch das ist bei mir der Fall. Man gelangt nicht mal mehr in die Mediathek.

Weiter schreibt WP-Forenteilnehmer “Stern2”: Lustig dabei ist aber, dass das Bild dann trotzdem da ist, wenn ich über “Medien” die Daten aufrufe.

Auch das ist hier der Fall. Das Bild wird augenscheinlich komplett hochgeladen, aber ist nicht sichtbar in der Mediathek.

Ein anderer hat das gleiche Problem und schreibt, daß er jedesmal bei Bilderhochladen das “plugin” deaktiviere.

Habe mir so geholfen, daß ich das Plugin (habe als nur den “Audioplayer”) deaktiviert habe und nicht über den Beitrag die Bilder hochlade, sondern extra über “Medien” -> “Dateien hinzufügen”. Anschließend muß ich zwar das Plugin wieder aktivieren – aber immerhin, so gehts.Ist natürlich viel umständlicher als mit der Vorversion. Irgendwo ist da der Wurm drin, aber ich weiß leider nicht wo.

Bei Internetzeitungen wie Polizei24.ch mit täglich dutzenden Meldungen kann man sich da gleich erschießen. Das kann also kaum die Lösung sein.

Schließlich schreibt jemand:

Da ich noch weitere 42 WordPress Blogs habe, testete ich einen anderen Blog mit V3.5 und siehe da, es geht ohne Fehler im IE.

Es scheint also nicht an WP zu liegen, sondern an meinem (Theme, Plugin) von WooCommerce. Wootique 1.5 mit Framework 5.5.3 und WooCommerce 1.6.6.

Es ist also wohl so, daß diese Version von WP 3.5 nicht nur massiv umständlicher ist, sondern massenhaft Erweiterungen (plugins) zerfetzt bzw. unbrauchbar macht. Daß es mit den “plugins” zusammenhängt, darauf weist auch hin, daß bei Deaktivierung und anschließender Aktivierung der Erweiterungen das Bild-hochladen problemlos geht.

Ein anderer allerdings schreibt, daß das nichts gebracht hat: Also ich habs mit dem neuen 2012 Theme versucht, alle Plugins deinstalliert.  Leider gleiches Problem.

Noch mysteriöser ist dieser Tipp, der aber anscheinend geholfen hat:

Also, ich habe entdeckt, daß die neue Version 3.5 eine Datei .htaccess im “uploads”-Verzeichnis anlegt, das habe ich wieder gelöscht und schon waren die Bilder wieder wie in der alten Version gewohnt zu sehen. Der Inhalt der htaccess Datei war sowieso unsinnig/unvollständig.

Besonders kraß finde ich, daß im WP-Forum bis jetzt noch niemand wirklich eine Lösung gefunden hat.

Nachzulesen hier (ganzer Strang).


Share

Noch eine Fehlfunktion von WP 3.5: Bild-Großklicken geht nicht mehr…

Das Bildhochladen wird zum Krampf, die Admin langsam usw. Darüber schrieb ich in früheren Beiträgen, in welchen ich mich enttäuscht ärgerte.

Und heute habe ich noch entdeckt, daß wenn man auf SchweizBlog.ch Bilder / Fotos anklickt, daß sich die nicht mehr vergrößern lassen, sondern eine Fehlermeldung vom Hoster (Hostmonster, einer der größen Hoster der USA, an dem wird es also nicht liegen) kommt.

WP 3.5: Bild anklicken und großklicken dadurch? Fehlanzeige!

WP 3.5: Bild anklicken und großklicken dadurch? Fehlanzeige!

Ein Kommentator “Volker aus Hamburg” schreibt hier:

… / … Und dennoch:

– das Hochladen von Bildern wurde komplizierter und unübersichtlicher (Stichwort: Mediathek)

– der Speicherverbrauch (Memory) auf dem Server hat sich nochmals erhöht

Genau das mit dem Bildhochladen hab ich auch schon beschrieben. Ein absoluter Krampf bzw. eine Verschlimmbesserung und Verlangsamung. Besonders für Leute, die viel redaktionell arbeiten.

Ein anderer Kommentator kritisiert:

… / … Hier sollte das Entwicklerteam bewußter arbeiten. Sicher, es konnte mithilfe eines Plugin umgangen werden – das kann ja aber nicht Sinn und Zweck sein. Ich warte lieber noch ein bißchen. Erstmal soll sich eine neue Version etablieren und beweisen, das sie ordnungsgemäß läuft.

Ja, dem kann man nur zustimmen. Schade.

 

Share

WP 3.5: Warum eigentlich “Text” anstatt “HTML”?

früher: "visuell" und "HTML". Ganz einfach.

früher: “visuell” und “HTML”. Ganz einfach.

Bisher war die visuelle Ansicht die Textansicht und die andere die HTML-Ansicht bei WordPress.

Seit WP 3.5 gibt es eine Version der Ansicht die heißt Text anstatt HTML?

Was soll das eigentlich?

Kann mir das jemand erklären?

Früher war “visuell” die visuelle Ansicht und HTML halt HTML-Kode.

Und jetzt gibt es anstatt “visuell” und “HTML” anstattdessen “visuell” und “Text”?

Das, was jetzt Text heißt, ist aber gar kein Text, sondern HTML.

Also, was soll das bitte bei WP 3.5?

Wordpress 3.5: "visuell" und "Text" anstatt "visuell" und "HTML". Was soll das? Das, was unter Text ist, ist HTML und kein Text, wie es neu heißt.

WordPress 3.5: “visuell” und “Text” anstatt “visuell” und “HTML”. Was soll das? Das, was unter Text ist, ist HTML und kein Text, wie es neu heißt. Oder kann man jetzt keinen HTML-Kode mehr auf WP einfügen?!

 

Share

+++ REKLAME: